[社群QA] Zabbix“专家坐诊”第88期问答汇总

[复制链接]
乐维 发表于 2020-12-10 10:12:07 | 显示全部楼层 |阅读模式 打印 上一主题 下一主题
Q:请问下,我有个外部工具,从其他数据库抓取数据传到zabbix server上,在zabbix server界面上应该怎么配置items? type 和key应该怎么写
1.jpg
A:如果使用zabbix_sender的话用这个,key需要与sender的相同
2.jpg
Q:等于说 外部工具将数据发送给sender,然后sender转发给zabbix server?
A:对,方法很多,也可以用zabbix的自定义键值,或者使用外部监查
Q:我想将elasticsearch的数据传给zabbix,然后处理一部分的数据做告警,主要想实现告警历史记录和告警升级,应该怎么做比较好? 比如是es先抓到错误信息推送给zabbix,还是直接将数据全部抽到zabbix server,zbx自己处理?
A:都可以,根据服务器性能去做判断
Q:我想将特定的数据交给zabbix,有什么工具推荐?
A:zabbix_sender就可以了

Q:zabbix的内存缓存一直在递增,清除内存缓存后,会对监控数据,告警有什么影响码?
A:不会有什么影响
Q:好的,谢谢

Q:客户又Red hat 4.5的系统要监控, zabbix-agent有支持4.x的吗?
A:支持
Q:谢谢

Q:请问下,我现在准备清理下zabbix的数据库里的history记录,占用磁盘太大了,需要停止server一段时间,然后清理完毕后再启动server,那这段时间如果有触发的报警在启动后也会触发吗?
A:不会的
Q:只有启动server后触发的报警才生效?那有什么办法能将这段关闭server时间内的报警在启动后生效呢
A:最新数值达到阈值就会告警

Q:打扰问下,生产环境zabbix4.4部署在centos7 上,现在想升级到5.2版本,尝试了下发现办法像之前一样直接用yum升级到5.2了,您这有什么相对简单的办法么?
A:5.0的zabbix版本升级的较多东西,php也升级了,如果不升级php的话可能无法打开页面
A1:5.0要求php,最低7.2.0
A:是的
Q:我知道要升php,5.0刚发布的时候在centos7+zabbix4.4测试环境试过可以升级到5.0,现在想从4.4直接升级到5.2没法升级了,您这有什么实践么?
A:可以升级
Q:自己下5.2服务端源码编译安装么?
A:http://www.lwops.cn/forum.php?mo ... =%E5%8D%87%E7%BA%A7级与这个方法类似,参考这个方法升级
Q:好,我跟着试试编译吧,谢谢
A:5.0需要php7.2,php也需要升级
Q:好,我先升5.0再升5.2试试吧,谢谢

Q:我docker安装的zabbix  编译时没有安装zabbix-gatway  现在想要监控JMX应该怎么办?
A:可以单独编译安装zabbix-getway
Q:噢噢 ~  是不是和proxy差不多?
A:可以这样理解,是zabbix的拓展功能模块
Q:好的   谢谢

Q:监控proxy离线告警有没有好的方法?
A:将proxy纳入监控
Q:我看了一下没有专门监控proxy的模板呀
A:proxy是linux吗,是Linux的话可以用Linux的模板

Q:请问下remote command里如何调用zabbix自身的一些变量,可以这样吗?
A:宏值
Q:脚本里呢,能引用吗?
A:可以
Q:cmd.sh脚本里可以直接引用zabbix宏变量?
3.jpg
A:可以
Q:这么神奇,我去试试

讲座88.png










上一篇:Zabbix“专家坐诊”第87期问答汇总
下一篇:SUSE 安装后需要做的配置及相关命令
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝0

帖子319

发布主题

乐维社区

微信公众号

版权所有 © 2016-2021 九一乐维丨粤ICP备17007026号