[技术干货] 解决客户端连接mongodb提示版本过低问题

[复制链接]
乐维 发表于 2020-9-1 17:40:18 | 显示全部楼层 |阅读模式 打印 上一主题 下一主题
最近用mongodb客户端连接服务端的时候遇到个报错,提示版本过低。
下面是解决办法
客户端下载链接(下载的mongodb客户端版本需要大于等于服务端mongodb版本) https://fastdl.mongodb.org/linux/mongodb-linux-x86_64-rhel70-4.2.6.tgz
步骤:
1、tar -xf 解压下载好的文件
2、将解压出来的文件放到/usr/local下
#mv mongodb-linux /usr/local/mongodb
3、做软链
#ln -s /usr/local/mongodb/bin/mongo /usr/bin/
4、查看mongo命令行版本
# mongo  --version
图片1.png
PS:客户端版本可以向下兼容服务端版本,但无法向上兼容
技术交流欢迎加入Q群:177428068






上一篇:mysql5.6.45升级5.7.31
下一篇:zabbix通过proxy代理连接unixodbc监控oracle数据库一直报错
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关注0

粉丝0

帖子241

发布主题

乐维社区

微信公众号

版权所有 © 2016-2019 九一乐维丨粤ICP备17007026号